資格のまとめ

コマンドのソートはping-tの「コマ問プレミアムCCNA」と同じです。

CCENT(ICND1 640-822J)

特権

boot system

起動するiOSの場所を指定する。設定されていない場合はフラッシュメモリ内のIOSを使う。

(config)#boot system {flash <ファイル名> | tftp <ファイル名> <TFTPサーバーのIPアドレス> | ROM }

boot system flash

フラッシュメモリから起動

(config)#boot system flash c3620-ios.bin

boot system rom

ROMのブートヘルパーイメージ(minirom IOS)から起動

(config)#boot system rom

boot system tftp

tftpサーバから起動

(config)#boot system tftp c3620-ios.bin 192.168.1.1

clear mac-address-table dynamic

ダイナミックアドレスの消去。オプションなしだと全ダイナミックアドレスが消去される。

#clear mac-address-table dynamic [ addres <MACアドレス> interface <インターフェイス> vlan <vlanID> ]

copy

コピー元→コピー先の順番でコピーできる。シスコ試験ではコンフィグの保存問題でよく出題されるが実際はあんまり使わない…?

#copy startup-config tftp

disconnect

ローカルデバイスでセッションを終了(切断)する。対象セッションを中断しているときなど直接exitとかで抜けられないときに使用?
セッション番号を省略した場合はアスタリスクがついたセッションを中断。

#disconnect <セッション番号>

erase

指定したデバイスの内容を消去する。
NVRAMとstartup-configは同じ

#erase [ bootflash: | flash: | nvram:(startup-config)  ]

resume

中断したtelnetセッションを再開する。セッション番号を省略した場合はアスタリスクがついた直前のセッションを再開する。

#resume <セッション番号>

show arp

登録されたarpテーブル情報を全部表示。

#show arp

show ip arp

エントリを指定してarp情報を表示。

#show ip arp vlan2

show cdp

CDPのホールドタイマー(holdtime)や送信間隔(packets every)に関する情報を表示します。

#show cdp

show cdp entry

特定のシスコ機器の情報を表示する。アスタリスク(*)のみ入力した場合は全ての隣接機器の情報を表示する。
またデバイス名にもアスタリスクが使用できる。

#show cdp entry *

show cdp entry protocol

使用しているプロトコル情報のみを表示したい場合に使用。

#show cdp entry <デバイス名> protocol

show cdp entry version

バージョン情報のみ表示したい場合に使用。

#show cdp entry <デバイス名> version

show cdp neighbors

CDPにより収集した隣接機器に関する要約情報を表示する。
隣接Cisco機器のホスト名(Device ID)、インターフェース(Local Intrfce)、型番(Platform)などの情報を情報する。

#show cdp neighbors

show cdp neighbors detail

隣接Cisco機器の詳細情報を得る。インターフェース、ホスト名、型番に加え、IPアドレスやIOS、VTPドメイン名なども確認出来る。

#show cdp neighbors detail

show controllers

ケーブルの種類を表示する他、DTE/DCEの情報やクロックレートが設定されているかも分かる。
固定型ルータの場合、スロット番号の指定は不要

#show controllers [ <interface-type> <slot/port> ]

show flash

フラッシュメモリの中身を表示する。
※黒本だとflashの後にコロンをつけてるけどいらないっぽい

#show flash

show frame-relay map

現在のフレームリレーマップとPVCのステータスを表示する。IPアドレスとDLCIの対応付けも確認できる

#show frame-relay map

show interfaces

インターフェイスの詳細な情報を表示。コマンド末尾に「s」がついているので忘れないように注意。
特定のインターフェイスを指定しない場合、そのデバイスの全てのインターフェイス情報を表示する。
cdpより前半部分に重要情報が集約されている感じ。

#show interfaces serial 0

show ip interface brief

インタフェースのIPアドレスやステータス等を簡易的に一覧表示させる。
リンクアップの状態を確認したり。

#show ip interface brief

show mac-address-table

MACアドレステーブルを表示する

#show mac-address-table

show sessions

中断しているセッションの確認。IPアドレスやセッション番号などがわかる

#show sessions

write

ファイルのコピーを行ったり、設定を保存したいときに使用される。
""copy running-config startup-config""と同じ。 構文が簡単。IOS 10.3以前から使用している。

#write

write erase

NVRAMにあるstartup-configを削除

#write erase

write memory

writeと同じ

#write memory

write network

TFTPサーバに設定を保存

#write net [  server  : [ filename ] |  :  filename ]

write terminal

running-configを表示

#write terminal

グローバル/インターフェイス/その他

banner motd

ルーターにログインした際にバナーメッセージを表示させる。
このメッセージは警告を示す内容にするのが望ましい。安易に「Wellcom!!」的なものは不適切とされる。

(config)#banner motd <区切り文字(#とか)> <表示したいメッセージ> <区切り文字(最初の区切り文字と同じにする)>

transport input

リモート接続を許可する。telnetとsshが対象。
片方だけ許可したい場合はコマンドのオプションに許可したい方のプロトコルだけ入力すればおk。

(config-line)#transport input ssh telnet

show ip ssh

sshが有効(Enable)か確認できる。

#show ip ssh

show ssh

sshでのログイン状況を確認できる。

#show ssh

enable secret

暗号化されたパスワードを設定する。
enable passwordコマンドも設定されている場合はこちらが優先される。

(config)#enable secret [値(0〜15)] {<パスワード本文>|<暗号化タイプ()現在は7のみ><暗号化されているパスワード>}

enable password

暗号化されていない平文でパスワードを設定。
暗号化するにはenable secretかservice password-encryptionコマンドを使用する。

(config)#enable password [値(0〜15)] {<パスワード本文>|<暗号化タイプ()現在は7のみ><暗号化されているパスワード>}

interface

任意のインターフェイスに移行する。

(config)#interface serial 0

bandwidth

インターフェイスの帯域幅を設定。デフォルトでkbps単位になる。

(config-if)#bandwidth 64

line

指定のラインモードへ移行する。
 (config)#line [ aux | console | tty | vty ] ライン番号 [ 終了番号 ]

password

コンソールやvty接続をする際のパスワードを設定する。
オプションで0(クリアテキスト)か7(暗号化)を指定できる。デフォルトはたぶん0

(config-line)#password [ 0 | 7 ] [パスワード本文]

login

passwordコマンドを有効にする。IOSのバージョンによってはpasswordとloginの順番が逆になるらしい。

(config-line)#login

config-register

ルータのコンフィグレジスター値を変更する。レジスター値は頭に「0x」を付けるのを忘れずに。

(config)#config-register 0x2142

ip address

対象ラインのIPアドレスを設定。
no ip addressで設定されたIPアドレスを削除できる。

(config-if)#ip address 192.168.1.1 255.255.255.0

clock rate

DCE側のクロックレートを設定する。単位はbps。

(config-if)#clock rate 64000

no cdp enable

対象インターフェースでcdpを無効にする

(config-if)#no cdp enable

no shutdown

インターフェイスを有効化。デフォルトではno shut down状態。
shutdwonで無効化状態にできる。

(config-if)#no shutdown

duplex

デュープレックスを指定。

(config-if)#duplex [ auto | full | half ]

speed

対象ポートの速度を指定。デフォルトはauto。

(config-if)#speed [ auto | 10 | 100 ]

service password-encryption

すべてのパスワードを有効にする。

(config)#service password-encryption

no ip domain-lookup

ルータの名前解決を無効にする。デフォルトでは有効。
(ip domain-lookupの状態)←コマンドをミスったときにも名前解決をしようとするので鬱陶しい。

(config)#no ip domain-lookup

description

インターフェイスにメモを残す。

(config-if)#description <残したいメッセージ>

スイッチング

ip default-gateway

デフォルトゲートウェイの設定。サブネットマスクは必要ない。
no ip default-gatewayで無効化。

(config)#ip default-gateway 192.168.1.1

show interfaces status

スイッチポートの情報を要約して表示。

#show interfaces status

show port-security

指定したインターフェイスのポートセキュリティの状態を表示。
addressオプションで全ポートのセキュアMACアドレスを表示。
オプションなしだと設定してあるやつだけ表示(たぶん)

#show port-security { interface <インターフェイス番号> | address }

switchport port-security

ポートセキュリティを有効化。
no switchport port-securityで無効化(デフォルト)

(config-if)#switchport port-security

switchport port-security mac-address sticky

ダイナミックに学習されたMACアドレスを自動的にスタティックセキュアMACアドレスとしてrunning-configに追加する。

(config-if)#switchport port-security mac-address sticky

switchport port-security maximum

セキュアMACアドレスの数を設定(1〜132まで。デフォルト:1)

(config-if)#switchport port-security maximum <1〜132の数値>

switchport port-security violation

ポートセキュリティにおける違反モードの設定。デフォルトはshutdown

(contig-if)#switchport port-security violation [ protect | restrict | shutdwon ]

ルーティング

debug ip rip

RIPのルーティングアップデートの様子をモニタリングできる。
送信したアップデートの内容など詳細な情報が表示される。

#debug ip rip

debug ip rip database

RIPのデータベース構築の様子をモニタリングできる。

#debug ip rip database

debug ip rip events

debug ip ripコマンドの出力結果を要約して表示。
アップデートを受信したかブロードキャストしたか位でその中身までは表示されないぽい。

#debug ip rip events

ip classless

不明なサブネット宛のパケットが来た場合にデフォルトルートによってルーティングする。
デフォルトで有効。無効にした場合は不明なパケットは破棄する。

(config)#ip classless

ip route

手動でルーティングの経路を設定する。permanentを指定するIFがシャットダウンしても経路情報が削除されない。デフォルトルートの設定は「ip route 0.0.0.0 0.0.0.0 <ルーティング先アドレス>」
ネクストホップアドレスはポイントツーポイントの場合はS0/0などインターフェイスで指定できる。
AD値を変更してバックアップ回線として設定したり。

(config)#ip route [宛先アドレス] {ネクストホップアドレス | インターフェイス} [AD値] [permanent]

network

指定したクラスフルネットワークでRIPを使用する。クラスフルアドレスな点に注意!
まずはrouter ripコマンドでRIPを有効にしておく。

#network 192.168.1.0

passive-interface

ルーティングアップデートを停止する。defaultオプションで全てのインターフェースのアップデートを停止する。ただしアップデートの受信はする。

(config-router)#passive-interface serial 0

router rip

RIPを起動。デフォルトではRIPv1だが、router ripコマンド実行後に「version 2」コマンド実行で、RIPv2になれる。
noを頭につければ無効にできる。

(config)#router rip

show ip protocols

現在ルーターで有効なプロトコルを表示する。アップデートの間隔と次回アップデートまでの秒数、
各種タイマー、ルート情報の送信元の情報、アドミニストレーティブディスタンス値など色々確認できる。

#show ip protocols

show ip rip database

RIP関連のデータベース情報を表示する。

#show ip rip database

show ip route

ルーティングテーブルを表示。オプションでcnnectedやstaticを付けて表示する内容の絞り込みが可能。

#show ip route

WAN/PPP

debug ppp

pppパケットのデバックをモニタリング。
authenticationでPAPとCHAP認証。negotiationでリンクネゴシエーション。

#debug ppp authentication

encapsulation

カプセル化タイプを指定。PPP、HDLC、flame-relayなど。

(config-if)#encapsulation ppp

ppp pap sent-username <自分のusesrname> password <自分のpass>

PAPを使う宣言をする。なんかCHAPでいらない様だがPAPだといるっぽい。

(config-if)#ppp pap sent-username R1 password cisco

username <name> password <pass>

PPPにおける認証情報の設定。<name>は相手側ルータのホスト名を指定。<pass>は両側のルータで共通のパスワードを指定。

(config)#username <R1> password <cisco>

ICND2(640-816J)

Frame relay

show interface serial0/0

インターフェイスのカプセル化やLMI情報を確認

show frame-relay lmi

LMI情報、トラフィック統計情報を確認

show frame-relay pvc

PVCトラフィック、ステータス、DLCIを確認

debug frame-relay lmi

ルータとローカルフレームリレースイッチ間でやりとりしているLMIログをリアルタイムで確認

STP

show spaning-tree

OSPF

show run

show ip protocols

show ip ospf

OSPFルーティングプロセスのプロセスID、ルータID、LSAの数やSPF計算の実行回数

show ip ospf interface

インターフェイスごとのOSPF情報表示

show ip ospf neighbor

show ip ospf database <lsa type>

debug ip ospf adj

EIGRP

show ip eigrp neighbors

show ip eigrp topology

show ip eigrp traffic

show ip route

debug ip eigrp

show ip protocols


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2014-05-05 (月) 15:17:34 (2019d)